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Application Note 

Design Models 

How to Create Symbols for PSpice Models 

ROHM provides the SPICE models for simulating circuits. The model files include the library and symbol files. However, if a model 

is not provided with a symbol file, symbols need to be created. This application note describes how to create the PSpice symbols. 

Since the symbols vary with simulators, refer to the manual of the simulator to be used when creating the symbols for the 

simulators other than PSpice. 

 

Configuration of provided SPICE models 

The SPICE models can be downloaded from the product pages on the ROHM website. An example of the model files is shown 

below. In this example, the library file and the symbol file for PSpice are shown on the left and right, respectively. If two files are 

provided as in this example, the model can be registered and used with the simulator. However, the symbol files may not be 

provided for some products. In such cases, the symbol files need to be created. 

 

 

 

 

 

 

Table 1. Example of the model files. Product name: BD9E300EFJ-LB 

How to create symbols 

This section introduces two methods using the OrCAD PSpice Designer (Ver. 17.2). Select method A to perform a simulation 

immediately. Select method B normally. 

A. Create the symbols using the PSpice Model Editor 

→ To perform a simulation immediately. When the symbol shape is irrelevant. 

B. Create the symbol library of the OrCAD Capture 

→ To create symbol files compatible with the element functions and use them for other projects as well. 

 

Item Library file Symbol file for PSpice 

File name BD9E300.lib BD9E300.olb 

Extension .lib .olb 

File format Text Binary 
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A. Create the symbols using the PSpice Model Editor 

1. Start the PSpice Model Editor. 

2. In the [File] menu, select [Export To Part Library…]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. When the [Create Parts for Library] window is 

displayed, select a library file (.lib) in [Enter Input 

Model Library:] where the symbol is created. Next, in 

[Enter Output Part Library:], specify the location and 

symbol name (.olb) to save the symbol. Finally, 

clicking [OK] automatically creates the symbol. 

 

 

 

 

4. To change the symbol shape, use the [Draw] menu on the right. 
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B. Create the symbol library of the OrCAD Capture 

For explanation, this section takes Nch Power MOSFET RD3G400GN as an example. 

Library file name: rd3g400gn_spice.lib 

1. Start the PSpice Model Editor. 

2. In the [File] menu, select [Model Import Wizard…]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. When the [Model Import Wizard] window is displayed, specify a library file (.lib) in [Enter Input Model Library:] where the 

symbol is created. When a library file is selected with [Browse…], the location and symbol name (.olb) to save the symbol 

file are automatically entered in [Enter Destination Symbol Library:]. If no issue is found, click [Next]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Next(N) > < Back(B) Cancel Help 
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4. When the [Associate/Replace Symbol] window is displayed, click [Associate Symbol]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. When the [Select Matching] window is displayed, click […] in the [Select library to pick matching symbols:] field to specify the 

[breakout.olb] file. This symbol file is usually located in the directory where the OrCAD PSpice Designer is installed. For 

example, the file may be found in the following location. 

Location of the [breakout.olb] file: C:¥Cadence¥SPB_17.2¥tools¥capture¥library¥pspice 
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6. In the list of symbols displayed in [Matching Symbols], select an appropriate symbol and click [Next]. In this example, 

[MbreakN3D] is selected for the Nch MOSFET model. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Regarding the question of which symbol included in [breakout.olb] should be used, any symbols can be used if the number 

of terminals matches. The usage examples are shown below. 

Device BREAKOUT symbol  Device BREAKOUT symbol 

Diode Dbreak 
 

 Pch MOSFET MbreakP3D 
 
 
 
 
 
 
 
 

Diode (2 in 1) Dbreak3 
 

 Bipolar NPN QbreakN 
 
 
 
 
 
 
 

Nch MOSFET MbreakN3D 
 

 Bipolar PNP QbreakP 
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7. When the [Define Pin Mapping] window is displayed, perform mapping of the terminal names of the SPICE model and the 

pin names of the symbol. Basically, the terminal names and order of the SPICE model are arranged as follows. 

 Diode  : 1. A (Anode), 2. K (Cathode) 

 MOSFET  : 1. D (Drain), 2. G (Gate), 3. S (Source) 

 Bipolar transistor : 1. C (Collector), B (Base), 3. E (Emitter)  

However, in rare cases, the order might be different for equivalent 

circuit models (subcircuit models). Therefore, it is necessary to 

check the description in the library file. As an example, the 

description in the library file for Nch MOSFET RD3G400GN is 

shown on the right. Since “D”, “G”, and “S” are arranged in the order 

of 1, 2, and 3, the basic description is confirmed. 

 

 

 

 

 

 

 

 

8. In the [Symbol Pin] field of the [Define Pin Mapping] window, assign the pin names in the order confirmed previously. When 

the assignment is completed, click [Save Symbol]. 
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9. In the [Associate/Replace Symbol] window, click [Finish]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

10. When the log window is displayed, confirm that no error has occurred. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11. Confirm that the symbol file (.olb) is created in the specified folder. This completes the creation of the symbol file (.olb). 

 

 

 

 

  

Finish < Back(B) Cancel Help 

ERR File 

LIB File 

OLB File 
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From here, the usage of the symbol file (.olb) is explained. 

12. Open the project file in the OrCAD Capture. 

13. First, add the symbol to the library. Right-click on the [Library] folder in [Design Resources] and select [Add File] from the 

pop-up menu. When the file selection window is displayed, select the created [.olb] file. Confirm that the symbol is added 

to the [Library] folder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

14. Alternatively, while the circuit diagram is open, select [Place] and then [Parts] in the menu bar. The [Place Part] window is 

displayed on the right edge. In the [Libraries:] field, clicking the [Add Library] icon displays the [Browse File] window. Select 

the created [.olb] file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Add Library 

[Place Part] window 
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15. The added symbol file (.olb) is displayed in the Part List. Double-click the part to place the symbol on the circuit diagram. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16. Next, link the library file (.lib) to the project. In the menu bar of the circuit diagram, select [PSpice] > [New Simulation Profile] 

to open a new simulation profile. When the [New Simulation] window is opened, enter an appropriate simulation name in 

[Name:] and click [Create]. 

 

 

 

 

 

 

 

 

 

To open an existing simulation profile, select [PSpice] > [Edit Simulation Profile] in the menu bar. 

 

 

  

Double-click to place the symbol on the circuit diagram 
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17. When the [Simulation Settings] window is opened, select [Configuration Files] in the left column and select [Library] in the 

[Category:] field. Next, click [Browse…] to select the library file (.lib). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

18. According to your purpose, select one of the [Add…] buttons in the right column to add the library file. 

 a. [Add as Global]: The library file is linked to all project files of OrCAD. 

 b. [Add to Design]: The library file is linked only to this project file. 

 c. [Add to Profile]: The library file is linked only to this simulation profile. 

19. Click the [Apply] button and then the [OK] button to complete the setting. 
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Notice

ROHM  Customer Support System 
http://www.rohm.com/contact/

Thank you for your accessing to ROHM product informations.  
More detail product informations and catalogs are available, please contact us. 

N o t e s  

The information contained herein is subject to change without notice. 

Before you use our Products, please contact our sales representative and verify the latest specifica-
tions :

Although ROHM is continuously working to improve product reliability and quality, semicon-
ductors can break down and malfunction due to various factors.
Therefore, in order to prevent personal injury or fire arising from failure, please take safety 
measures such as complying with the derating characteristics, implementing redundant and 
fire prevention designs, and utilizing backups and fail-safe procedures. ROHM shall have no 
responsibility for any damages arising out of the use of our Poducts beyond the rating specified by 
ROHM.

Examples of application circuits, circuit constants and any other information contained herein are 
provided only to illustrate the standard usage and operations of the Products. The peripheral 
conditions must be taken into account when designing circuits for mass production.

The technical information specified herein is intended only to show the typical functions of and 
examples of application circuits for the Products. ROHM does not grant you, explicitly or implicitly, 
any license to use or exercise intellectual property or other rights held by ROHM or any other 
parties. ROHM shall have no responsibility whatsoever for any dispute arising out of the use of 
such technical information.

The Products specified in this document are not designed to be radiation tolerant.

For use of our Products in applications requiring a high degree of reliability (as exemplified  
below), please contact and consult with a ROHM representative : transportation equipment (i.e. 
cars, ships, trains), primary communication equipment, traffic lights, fire/crime prevention, safety 
equipment, medical systems, servers, solar cells, and power transmission systems.

Do not use our Products in applications requiring extremely high reliability, such as aerospace 
equipment, nuclear power control systems, and submarine repeaters.

ROHM shall have no responsibility for any damages or injury arising  from non-compliance with 
the recommended usage conditions and specifications contained herein.

ROHM has used reasonable care to ensure the accuracy of the information contained  in this 
document. However, ROHM does not warrants that such information is error-free, and ROHM 
shall have no responsibility for any damages arising from any inaccuracy or misprint of such 
information.

Please use the Products in accordance with any applicable environmental laws and regulations, 
such as the RoHS Directive. For more details, including RoHS compatibility, please contact a 
ROHM sales office. ROHM shall have  no responsibility for any damages or losses resulting 
non-compliance with any applicable laws or regulations.

When providing our Products and technologies contained in this document to other countries,  
you must abide by the procedures and provisions stipulated in all applicable export laws and 
regulations, including without limitation the US Export Administration Regulations and the Foreign 
Exchange and Foreign Trade Act.

This document, in part or in whole, may not be reprinted or reproduced without prior consent of 
ROHM.
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