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Solist-AI™ Starter Kit 
Solist-AI™ Starter Kit Start Guide 

 
 

Thank you very much for purchasing the Solist‑AI™ Starter Kit (hereafter referred to as “this starter kit”). 
This starter kit contains the boards and cables listed below. 
Please check first to ensure that no items are missing. 
 

Table 1  Contents of This Starter Kit 
Item Quantity 
Solist-AI™ Starter Kit Start Guide (Japanese/ English) (this document) 1 each 
RB-D63Q2557TB64 (Reference board equipped with Solist‑AI™ MCU ML63Q2557) 1 
KXTJ3-1057-EVK-001 (Acceleration sensor board) 1 
MM-FT232HC (Multi‑function USB conversion module) 1 
Jumper cables (female‑female) 15 cm (red/black/blue/green) 1 each color 
USB cable USB2.0 Type‑A male ⇔ Type‑C male 0.5 m 1 

 
If any item is missing or defective, please contact ROHM. 
For questions regarding the Sanhayato MM‑FT232HC included in this starter kit, please also contact ROHM. 
 
 When developing software using this starter kit, please prepare a debug adapter separately on your own. 
 This starter kit comes with a sample program pre‑written to the Solist‑AI™ MCU (ML63Q2557) on the 

RB‑D63Q2557TB64 board (hereafter referred to as the reference board) so that you can evaluate the functions of 
Solist‑AI™. 

 Since this manual was created using tools available at the time of development, the versions and screen displays may 
differ. 

 
■Stand‑Alone Operation 

Here, you can check the operation of the anomaly detection sample program that uses an acceleration sensor, which has been written 
to the Solist‑AI™ MCU (hereafter referred to as the “anomaly detection sample program”). 
The anomaly detection sample program calculates the anomaly score using sensor input values and displays the results in 
Solist‑AI™ Scope. 
 

1. Downloading and Installing Solist‑AI™ Scope and Sample Program 
1-1. Access the URL below and download the following from the displayed page: 

“Solist-AI™ Scope (Real-Time Waveform Display Tool) ”,  
“AI Libraries for Anomaly Detection Using Accelerometers”, and 
“Anomaly Detection Using Accelerometers and AI Library”. 
<https://www.rohm.com/products/micon/solist-ai/ml63q2500-group/ml63q2557-nnntb_taping_-product#developmentSupportsubmenu> 

 
1-2. Extract the downloaded file Solist‑AI_Scope_x.x.x.zip (where x.x.x indicates the version) and install Solist‑AI™ Scope. 

For installation instructions, refer to FEXT63Q2500_SOLIST‑AI_SCOPE_UG‑xx.pdf (where xx indicates the revision number) 
located in the Document folder. 
Extract Solist-AI_FW_AnomalyDetectionSample_yyyymmdd.zip (where yyyymmdd indicates the version) to any folder of your 
choice. 
 Use only half‑width alphanumeric characters in paths and folder names (no spaces).  

 
2. Connections 

2-1. Connect the reference board and the MM‑FT232HC as shown below.  

 

 

 

 

 

 

Figure 1  Connecting MM-FT232HC and the Reference Board 
 

2-2. Connect the reference board and the KXTJ3‑1057‑EVK‑001 using jumper cables. 

 

 

 

 

 

 

 

 

 
Reference Board 

CN2 No. 
Signal Jumper 

Cable Color 
KXTJ3-1057-EVK-001 

J1 No. 
1 +3.3V Red 6 

29 SDA Blue 7 

30 SCL Green 5 

33 GND Black 8 

Figure 2  Connecting the Reference Board and KXTJ3-1057-EVK-001 
 

2-3. Connect the MM‑FT232HC to the PC using a USB cable. 
The pre‑written program in the Solist‑AI™ MCU will start running, the LED (P50) on the reference board will blink, and the LED 
on the KXTJ3-1057-EVK-001 will turn on. 

 

 

 

 

 

 

 

 

Figure 3  Overall Connection Diagram 
 

 

 

 

 

 

 

 

 

 

 

 

3. Checking Operation with Solist‑AI™ Scope  
3-1. Launch Solist‑AI™ Scope. 

Double‑click the shortcut created during installation to launch Solist‑AI™ Scope. 
If you did not create a shortcut, open it from the Windows Start menu by selecting [All Apps] > [ROHM] > [Solist‑AI Scope 
ML63Q25xx]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4  Startup screen of Solist-AI™ Scope 
 
3-2. From File > Mapfile in Solist‑AI™ Scope, specify the map file of the anomaly‑detection sample program to be referenced. 

 
 
 
 
 
 
 

Figure 5  Specifying the MAP File 
 
Please specify the map file located in “samples\Solist-AI\AnomalyDetectionDemo\Debug\AnomalyDetectionDemo.map” under 
the folder where Solist-AI_FW_AnomalyDetectionSample_ yyyymmdd.zip was extracted. 

 
3-3. Specify the signals (variables) to be displayed in Solist‑AI™ Scope.  

Check Ch0 to Ch3 under Ch, select the desired signal (variable) under Source, and specify the data type under Type. 
i2AccOutX_ / i2AccOutY_ represent the X/Y‑axis values of the accelerometer, 
learning_loss indicates the error during learning, and 
output_loss represents the anomaly score. 
 
Use the Zoom button  to adjust the display range. 
For acceleration sensor values, set the Zoom to 2000–5000. 
For error and anomaly score, adjusting the Zoom to 0.01 or below provides better visibility. 
The adjusted values will be displayed in each channel’s field. 
 
 
 
 
 
 
 
 
 
 

Figure 6  Specifying Signals to Display and Adjusting Values 
 

3-4. When Solist‑AI™ Scope receives data, the changes in the values are displayed in the graph area. 
You can observe how the values change by tilting or moving the KXTJ3‑1057‑EVK‑001. 
 
In Figure 7, the system is trained to treat the state without vibration as normal. 
Set the sensor in a vibration‑free condition and click the [Train] button in Solist‑AI™ Scope. 
The value of “learning_loss” will increase once, indicating that learning is in progress. 
When the value returns to its original level, the learning process is complete. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7  Example of Value Changes (During Training) 
 
In Figure 8, after clicking the [Monitor] button in Solist‑AI™ Scope to switch to prediction mode, the sensor is shaken or otherwise 
moved to create a condition different from the learned normal state and confirm that anomalies are detected. 
An anomaly is indicated where the value of “output_loss” becomes large. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8  Example of Value Changes (During Monitoring) 
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■Operation Using Development Tools 

Here, we explain an example of building the anomaly detection sample program using the development support system, writing it to 
the Solist-AI™ MCU ML63Q2557, and running it. 
 When developing software using this starter kit, please prepare a debug adapter separately on your own. 

 
 
 
 
 
 
 
 
 
 
 
 

Figure 9  System configuration with Development Tools 

 
4. Downloading and Installing Development Environment 
4-1. Access the following URL, download “ML63Q2500 Software Pack (device information files)” and “LAPIS Development Tools 

LEXIDE-Ω” from the displayed page, and extract them to any folder. 
<https://www.rohm.com/products/micon/solist-ai/ml63q2500-group/ml63q2557-nnntb_taping_-product> 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 10  Locations Related to the Development Support System Software 
 
Access the following URL and download the file “ARM.CMSIS.x.x.x.pack” (where x.x.x represents the version) from the displayed 
page. 
<https://www.keil.arm.com/packs/cmsis-arm/versions/> 
 

4-2. Install LAPIS Development Tools LEXIDE-Ω. 
Run LexideInstaller_yyyymmdd.exe. 
Follow the instructions in the installer to complete the installation. 

4-3. Install ML63Q2500 Software Pack and ARM.CMSIS.x.x.x.pack. 
First, launch LEXIDE-Ω. 
Select Windows Start > All Apps > LAPIS LEXIDE Tools > LEXIDE-Ω.  
When the [Select a directory as workspace] dialog appears, set the workspace to “C:\lexide\workspace_omega_v2_arm” and click 
the [Launch] button. 
 
 
 
 
 
 

Figure 11  Starting LEXIDE-Ω 
 
After LEXIDE‑Ω starts, display the CMSIS‑Pack Manager. 
You can open the CMSIS‑Pack Manager by clicking the icon  in the upper‑right corner of LEXIDE‑Ω to open the [Open 
Perspective] dialog, selecting [CMSIS‑Pack Manager], and then clicking [Open]. 
 
 
 
 
 
 
 
 
 

Figure 12  How to open CMSIS-Pack Manager 
 
Click [Import existing packs…] in the displayed [CMSIS‑Pack Manager] perspective. 
In the [Import Packs] dialog that appears, specify ROHM.ML63Q25x7_DFP.x.x.x.pack (where x.x.x represents the version) from the 
folder you downloaded and extracted, and then click the [Open] button. 
 
 
 
 
 
 
 
 
 
 

Figure 13  Import ML63Q2500 Software Pack 
 
Similarly, in the [Import Packs] dialog, specify ARM.CMSIS.x.x.x.pack and install it. 
 
 
 
 
 
 

Figure 14  Import ARM.CMSIS.x.x.x.pack 

 
 

5. Importing the Anomaly Detection Sample Program 
Use the “Import” function in LEXIDE‑Ω to load the anomaly‑detection sample program project. 

5-1. From the File menu in LEXIDE‑Ω, select [Import...] to open the Import dialog box. 
5-2. In the Import dialog box, select [General] > [Existing Projects into Workspace], then click [Next]. 
5-3. Specify the folder that contains the project files for the sample program under [Select root 

directory](samples\Solist-AI\AnomalyDetectionDemo) and click the [Finish] button. 
 
 
 
 
 
 
 
 
 

Figure 15  Importing the Sample Program Project 
 

6. Building the Anomaly Detection Sample Program 
Configure the build options and then perform the build. 

6-1. From the [Project] menu in LEXIDE‑Ω, select [Properties] to open the [Properties] dialog. 
6-2. If the directory indicating the CMSIS version under [C/C++ Build] > [Settings] > [Tool Settings] tab > [Compiler] > [Includes] 

differs from the version you actually installed, change it to match the installed version. 
 
 
 
 
 
 
 

Figure 16  Include Path Settings 
 
6-3. In the [Project Explorer], select the project (AnomalyDetectionDemo), and click the button  on the toolbar to build the project. 

When the build is complete, “Build Finished.” will be displayed in the [Console] view. 
Please make sure that no errors have occurred. 

 
 
 
 
 
 

Figure 17  Build 
 

7. Debugging 
Configure the debug settings and start debugging. 
This manual describes the procedure when using a CMSIS‑DAP debug adapter. 
 The method for configuring the debug settings varies depending on the debug adapter you are using. 
 For details on how to configure the settings and perform debugging, refer to Chapter 6 “Arm Debugging Features” in 

the LEXIDE‑Ω for ARM Core Microcontrollers User’s Manual. 
7-1. In the [Project Explorer], select the project, then right‑click and choose [Debug As] > [Debug Configurations…] from the popup 

menu to open the [Debug Configurations] dialog. 
 
 
 
 
 

Figure 18  How to Open the [Debug Configurations] Dialog 
 

7-2. In the [Debug Configurations] dialog, select [LAPIS GDB Debugging (Arm)], click the [New launch configuration] button  to 
create a debug configuration, and then select CMSIS‑DAP under the [Debugger] tab in [Target ICE]. 
 
 
 
 
 
 

Figure 19  Creating a New Debug Configuration 
 
Click the [Close] button to close the [Debug Configurations] dialog. 
If a confirmation dialog appears asking whether to save the settings, click [Save] to save the configuration. 
 

7-3. In [Launch Configuration], select the debug configuration for the target you want to debug, and click the [Launch in ‘Debug’ mode] 
button  to start debugging. If a dialog appears asking whether to switch perspectives, click the [Switch] button. 
 
 
 
 
 
 

Figure 20  Starting Debugging 
 

7-4. The view switches to the debug perspective. Use the [Resume] button on the toolbar to run the program, the [Suspend] button to 
pause it, and the [Terminate] or [Stop] button to end the debug session. 
 

 
 
 
 
 
 
 
 
 
 
 

Figure 21  Debug screen 
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ROHM  Customer Support System

R2043A

The information contained in this document is intended to introduce ROHM Group (hereafter 
referred to asROHM) products. When using ROHM products, please verify the latest specifications 
or datasheets before use.

ROHM products are designed and manufactured for use in general electronic equipment and 
applications (such as Audio Visual equipment, Office Automation equipment, telecommunication 
equipment, home appliances, amusement devices, etc.) or specified in the datasheets. Therefore, 
please contact the ROHM sales representative before using ROHM products in equipment or 
devices requiring extremely high reliability and whose failure or malfunction may cause danger or 
injury to human life or body or other serious damage (such as medical equipment, transportation, 
traffic, aircraft, spacecraft, nuclear power controllers, fuel control, automotive equipment including 
car accessories, etc. hereafter referred to as Specific Applications). Unless otherwise agreed in 
writing by ROHM in advance, ROHM shall not be in any way responsible or liable for any damages, 
expenses, or losses incurred by you or third parties arising from the use of ROHM Products for 
Specific Applications. 

Electronic components, including semiconductors, can fail or malfunction at a certain rate. Please 
be sure to implement, at your own responsibilities, adequate safety measures including but not 
limited to fail-safe design against physical injury, and damage to any property, which a failure or 
malfunction of products may cause. 

The information contained in this document, including application circuit examples and their 
constants, is intended to explain the standard operation and usage of ROHM products, and is not 
intended to guarantee, either explicitly or implicitly, the operation of the product in the actual 
equipment it will be used. As a result, you are solely responsible for it, and you must exercise your 
own independent verification and judgment in the use of such information contained in this 
document. ROHM shall not be in any way responsible or liable for any damages, expenses, or 
losses incurred by you or third parties arising from the use of such information. 

When exporting ROHM products or technologies described in this document to other countries, you 
must abide by the procedures and provisions stipulated in all applicable export laws and regulations, 
such as the Foreign Exchange and Foreign Trade Act and the US Expor t Administration 
Regulations, and follow the necessary procedures in accordance with these provisions.

The technical information and data described in this document, including typical application circuits, 
are examples only and are not intended to guarantee to be free from infringement of third parties 
intellectual property or other rights. ROHM does not grant any license, express or implied, to 
implement, use, or exploit any intellectual property or other rights owned or controlled by ROHM or 
any third parties with respect to the information contained herein.

No part of this document may be reprinted or reproduced in any form by any means without the 
prior written consent of ROHM.

All information contained in this document is current as of the date of publication and subject to 
change without notice. Before purchasing or using ROHM products, please confirm the latest 
information with the ROHM sales representative. 

ROHM does not warrant that the information contained herein is error-free. ROHM shall not be in 
any way responsible or liable for any damages, expenses, or losses incurred by you or third parties 
resulting from errors contained in this document. 

Thank you for your accessing to ROHM product informations.
More detail product informations and catalogs are available, please contact us.

N o t i c e

© 2023  ROHM Co., Ltd. All rights reserved.

https://www.rohm.com/contactus
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