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NOTES 

1) The information contained herein is subject to change without notice.  
 

2) When using LAPIS Technology Products, refer to the latest product information (data sheets, user’s manuals, application 
notes, etc.), and ensure that usage conditions (absolute maximum ratings, recommended operating conditions, etc.) are 
within the ranges specified. LAPIS Technology disclaims any and all liability for any malfunctions, failure or accident 
arising out of or in connection with the use of LAPIS Technology Products outside of such usage conditions specified 
ranges, or without observing precautions. Even if it is used within such usage conditions specified ranges, semiconductors 
can break down and malfunction due to various factors. Therefore, in order to prevent personal injury, fire or the other 
damage from break down or malfunction of LAPIS Technology Products, please take safety at your own risk measures such 
as complying with the derating characteristics, implementing redundant and fire prevention designs, and utilizing backups 
and fail-safe procedures. You are responsible for evaluating the safety of the final products or systems manufactured by 
you. 

 

3) Descriptions of circuits, software and other related information in this document are provided only to illustrate the standard 
operation of semiconductor products and application examples. You are fully responsible for the incorporation or any other 
use of the circuits, software, and information in the design of your product or system. And the peripheral conditions must be 
taken into account when designing circuits for mass production. LAPIS Technology disclaims any and all liability for any 
losses and damages incurred by you or third parties arising from the use of these circuits, software, and other related 
information. 

 

4) No license, expressly or implied, is granted hereby under any intellectual property rights or other rights of LAPIS 
Technology or any third party with respect to LAPIS Technology Products or the information contained in this document 
(including but not limited to, the Product data, drawings, charts, programs, algorithms, and application examples、etc.). 
Therefore LAPIS Technology shall have no responsibility whatsoever for any dispute, concerning such rights owned by 
third parties, arising out of the use of such technical information. 

 

5) The Products are intended for use in general electronic equipment (AV/OA devices, communication, consumer systems, 
gaming/entertainment sets, etc.) as well as the applications indicated in this document. For use of our Products in 
applications requiring a high degree of reliability (as exemplified below), please be sure to contact a LAPIS Technology 
representative and must obtain written agreement: transportation equipment (cars, ships, trains, etc.), primary 
communication equipment, traffic lights, fire/crime prevention, safety equipment, medical systems, servers, solar cells, and 
power transmission systems, etc. LAPIS Technology disclaims any and all liability for any losses and damages incurred by 
you or third parties arising by using the Product for purposes not intended by us. Do not use our Products in applications 
requiring extremely high reliability, such as aerospace equipment, nuclear power control systems, and submarine repeaters, 
etc. 

 

6) The Products specified in this document are not designed to be radiation tolerant. 
 

7) LAPIS Technology has used reasonable care to ensure the accuracy of the information contained in this document. 
However, LAPIS Technology does not warrant that such information is error-free and LAPIS Technology shall have no 
responsibility for any damages arising from any inaccuracy or misprint of such information. 

 

8) Please use the Products in accordance with any applicable environmental laws and regulations, such as the RoHS Directive. 
LAPIS Technology shall have no responsibility for any damages or losses resulting non-compliance with any applicable 
laws or regulations. 

 

9) When providing our Products and technologies contained in this document to other countries, you must abide by the 
procedures and provisions stipulated in all applicable export laws and regulations, including without limitation the US 
Export Administration Regulations and the Foreign Exchange and Foreign Trade Act.. 

 

10) Please contact a ROHM sales office if you have any questions regarding the information contained in this document or 
LAPIS Technology's Products. 

 

11) This document, in part or in whole, may not be reprinted or reproduced without prior consent of LAPIS Technology. 
 
(Note) “LAPIS Technology” as used in this document means LAPIS Technology Co., Ltd. 
 

Copyright 2020 LAPIS Technology Co., Ltd. 
 
 

 
 

 
2-4-8 Shinyokohama, Kouhoku-ku, Yokohama 222-8575, Japan 

http://www.lapis-tech.com/en/ 
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Preface 

This application note describes the current consumption of  MK715x1 Evaluation Kit Mini (MK715x1EK1) and 
MK715x1 Evaluation Kit Mini Plus(MK715x1EK1P) equipped with Bluetooth® 5 compatible Bluetooth low energy 
module MK715x1 made by Lapis Technology. 
The following related documents are available, so please refer to them if necessary. 

 
■ MK715x1 Data Sheet 
■ MK715x1 Evaluation Kit Mini (MK715x1EK1) Hardware Manual 

 
Note: In this document, MK715x1 refers to both MK71511 and MK71521. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
•Bluetooth® is a registered trademark of Bluetooth SIG, Inc. 
•All other company and product names are the trademarks or registered trademarks of the respective companies. 
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1. Start up measurement environment 
1.1. Tool installation 

The current consumption is measured using the application "ble_app_pwr_profiling" for current consumption measurement 
of the sample software of nRF5 SDK provided by Nordic.  
 
Please download (free) the nRF5 SDK provided by Nordic from the following URL. 
https://www.nordicsemi.com/Software-and-tools/Software/nRF5-SDK 
 
Unzip the downloaded ZIP file to any folder. 
* Please do not use deep-paths and double-byte characters in the extracted folder. 
 
There are multiple development tools as a software development environment. This time we will use Embedded Studio 
provided by Segger. Please download the IDE (Integrated Development Environment) "Embedded Studio for ARM" (free) 
provided by Segger from the following URL. 
https://www.segger.com/downloads/embedded-studio/ 
 
Run the downloaded installation file. If you proceed with the installation according to the instructions, Embedded Studio 
and J-Link Device Driver will be installed. 
 

1.2. Activation of Segger Embedded Studio 
In order to use Segger Embedded Studio, activation (license authentication) operation is required first. When Embedded 
Studio is started for the first time, as shown in the figure below, the display screen indicating that the license has not been 
activated appears. You can perform activation operation from this screen. The MK715x1 has a Nordic chip, so it is a free 
license. Click "Activate Your Free License". The activation screen is displayed. 
 

 
Fig. 1-1 Initial screen prompting for activation 

 
 
 
 

  

https://www.nordicsemi.com/Software-and-tools/Software/nRF5-SDK
https://www.segger.com/downloads/embedded-studio/
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If you are using a PC that does not have an internet connection environment, you can copy the URL address for activation 
by right-clicking on "Activate Your Free License" and selecting "Copy Link". It is also possible to perform the activation 
offline from another PC with an internet connection environment. 
 

 
Fig. 1-2  Initial screen prompting for activation 

 
If you enter the necessary information on the activation screen below, the "Request License" button will be enabled, so 
click this button. The activation key will be sent to the specified email address. 
* An error may occur if "Co., Ltd" is added to Company. 
 

 
Fig. 1-3 Activation screen 

 
 
 
 
  



MK71511/MK71521 Application Note 
MK715x1 Current consumption measurement 

1. Start up measurement environment 

FEXK715x1_AN_Current-01 3 

When activating online, you can select the MAC address from the pull-down menu, but when activating offline, you need 
to check the MAC address of your PC and enter it. You can check the MAC address information of your PC by selecting 
“Tools” → “License Manager...” from the Embedded Studio menu and selecting “Diagnose Problems” from the License 
Manager screen. 
 

 
Fig. 1-4  MAC address confirmation screen 

 
Use Ctrl+C to copy the activation key included in the email sent by Segger. From the Embedded Studio menu, select 
"Tools" → "License Manager..." If you select "Activate Embedded Studio" from the License Manager screen, the License 
Manager window will be displayed with the activation key entered, as shown below. Click the "Install License" button at 
the bottom left. 
 

 
    Fig. 1-5  License key input screen 
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If the license installation is successful, the screen below will appear. 
 

 
Fig. 1-6  Screen after entering license key 

 
You can also see that it is licensed at the top of Embedded Studio. 
 

 
Fig. 1-7  Display example before and after activation 

 
※"Non-Commercial License" may be displayed even after activation. In this case, the activation will be reflected by 
opening the Embedded Studio project once. 
 
  

After activation 
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1.3. Adding code to the application program 

The application "ble_app_pwr_profiling" does not enter DCDC mode, it is necessary to add code to work in DCDC mode 
to the application program. 
 
Start Embedded Studio and select "File" -> "Open Solution..." from the menu to open the project file selection window.  
Select the project file (*.emProject) of "ble_app_pwr_profiling" and click open button.  
 
Since the project files used by MK71511 and MK71521 are different, select the project file according to the evaluation kit. 
 
MK71511： ble_app_pwr_profiling_pca10040e_s112.emProject 
MK71521： ble_app_pwr_profiling_pca10040_s132.emProject 
 

 
Fig. 1-8 Open project file 

 
When the project opens, select the source code "main.c" from the GUI left window and insert 
“sd_power_dcdc_mode_set(NRF_POWER_DCDC_ENABLE)” immediately after “ble_stack_init();” on line 783. 
 

 
Fig. 1-9 Add code 
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1.4. Build the application project 

After adding the setting to enter DCDC mode, please perform the build. 
From the Embedded Studio menu, select "Build" -> "Build <project name>" to start the build. 
When the build is completed normally, "Build complete" is displayed in the window under the GUI. 
 

 
Fig. 1-10 Build the project 

 
 
1.5. Writing the application program 

After the build is complete, write to the evaluation kit mini. 
Take the MK71521 Evaluation Kit Mini as an example. 
Connect the evaluation kit mini to a PC via USB to supply power. 
Connect the evaluation kit mini and J-Link. 
The figure below is a connection diagram when using MK71521EK1 and J-Link LITE. 
※Pay attention to the orientation of the cable connection. (Red circle) 
 

 

 
Fig. 1-11 Connection between MK71521 Evaluation Kit Mini and J-Link LITE 

 
 
 
 
  

J-Link LITE 

MK71521EK1 
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From the Embedded Studio menu, select “Target” → “Connect J-Link”. 
The display at the bottom of the GUI window changes from "Disconnected (J-Link)" to the display shown below. 
 

 
Fig. 1-12 Connection between J-Link and target board 

 
 

Erase the Flash ROM by selecting "Target" -> "Erase All" from the Embedded Studio menu. 
The following message will be displayed in the lower GUI window. 
 

 
Fig. 1-13 Erase Flash ROM 
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From the Embedded Studio menu, select "Target" → "Download <project name>" to write to the Flash ROM. 
The application program and SoftDevice will be written. 
When writing is completed, "Download successful" is displayed in the window below the GUI. 
 

 
Fig. 1-14 Program writing in Embedded Studio 

 
 
 
 
 
 
 
 

  



MK71511/MK71521 Application Note 
MK715x1 Current consumption measurement 

1. Start up measurement environment 

FEXK715x1_AN_Current-01 9 

1.6. Preparation of Evaluation Kit Mini 
Remove the resistor R18 (0Ω) to measure the current consumption of the BLE module alone. 
 

  
 

Fig. 1-15 MK715x1 Evaluation Kit DIP-SW with R18 (0Ω) Location 
 
Set all DIP-SW to off. 
 

 

           
Fig. 1-16  DIP-SW settings 

 
1.7. Connection with DC power analyzer 

Use a Keysight DC power analyzer (N6705). 
Connect the Output + side of the DC power analyzer to JP1 2pin of the evaluation kit and the Output - side to the GND of 
the evaluation kit. 
 
※J-Link remove from Evaluation Kit Mini 

 
Fig. 1-17  Connection diagram between MK715x1 Evaluation Kit Mini and DC power analyzer 

OFF 

ON 

DIP-SW R18(0Ω) 
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2. Current measurement 
After power on, if you set the DIP-SW 1 to OFF → ON → OFF, Advertise will start with the device name of 
"Nordic_Power_Mgmt". Use the DC power analyzer to get the current consumption during Advertise. 
※Advertise will stop in 30 seconds. If stopped, DIP-SW 1 to OFF → ON → OFF, again to restart Advertise. 
 
Launch BLE Tool on your smartphone while running Advertise and search for the device name of "Nordic_Power_Mgmt". 
Select "Nordic_Power_Mgmt" to start Connect. When Connect is completed, the screen changes to the screen shown below 
(right). Use the DC power analyzer to obtain the current consumption at the time of Connect. 
 
※Download the smartphone application "BLE Tool" from Google Play or the App Store. 
 

 
 Screen when device name "Nordic_Power_Mgmt" is detected          Screen when connecting 

 
Fig. 2-1  BLE Tool screen 
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3. Measurement data 
The measurement data of the current consumption is shown below. 
 
MK71511 evaluation kit mini Advertising 

 

 

 
  

STATE
Current

Consumption
[mA]

Actual Period
[us]

Current Consumption
 × Actual Period

[mA･us]

① Idle 0.0011 25716 28
② Pre-processing 2.1 71 149
③ Crystal ramp-up 1.4 496 694
④ Standby 0.4 970 388
⑤ Start radio 4.4 88 387
⑥  Radio Tx 5.7 329 1875
⑦ Radio switch 2.3 156 359
⑧ Radio Rx 5.6 47 263
⑨ Standby 1.0 262 262
⑩ Start radio 4.5 93 419
⑪  Radio Tx 5.7 316 1801
⑫ Radio switch 2.2 157 345
⑬ Radio Rx 5.6 48 269
⑭ Standby 0.9 261 235
⑮ Start radio 4.7 90 423
⑯  Radio Tx 5.9 315 1859
⑰ Radio switch 2.3 160 368
⑱ Radio Rx 5.5 49 270
⑲ Post-processing 1.0 376 376

0.03  sec 10770
Total Average Current 359 uA
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MK71511 evaluation kit mini Connection 

 
 

 
 

 
 
 
  

STATE
Current

Consumption
[mA]

Actual Period
[us]

Current Consumption
 × Actual Period

[mA･us]

① Idle 0.0011 27926 31
② Pre-processing 2.5 78 195
③ Crystal ramp-up 1.3 502 653
④ Standby 0.4 947 379
⑤ Start radio 3.2 44 141

⑦ Radio switch 2.1 151 317
⑧ Radio Tx 5.9 46 271
⑨ Post-processing 1.6 220 352

0.03  sec 2846
Total Average Current 95 uA

86 507⑥
Window widening

+ Radio Rx 5.9
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MK71521 evaluation kit mini Advertising 

 
 

 
 

 
  

STATE
Current

Consumption
[mA]

Actual Period
[us]

Current Consumption
 × Actual Period

[mA･us]

① Idle 0.0011 25732 28
② Pre-processing 3.5 71 249
③ Crystal ramp-up 1.4 506 708
④ Standby 0.4 933 373
⑤ Start radio 5.0 101 505
⑥  Radio Tx 6.2 322 1996
⑦ Radio switch 3.0 161 483
⑧ Radio Rx 6.4 45 288
⑨ Standby 1.4 257 360
⑩ Start radio 4.7 95 447
⑪  Radio Tx 6.2 314 1947
⑫ Radio switch 2.8 163 456
⑬ Radio Rx 6.4 45 288
⑭ Standby 1.3 258 335
⑮ Start radio 4.9 93 456
⑯  Radio Tx 6.4 314 2010
⑰ Radio switch 3.0 165 495
⑱ Radio Rx 6.4 45 288
⑲ Post-processing 1.6 380 608

0.03  sec 12320
Total Average Current 411 uA
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MK71521 evaluation kit mini Connection 

 
 

 
 

 
 
 
 
  

STATE
Current

Consumption
[mA]

Actual Period
[us]

Current Consumption
 × Actual Period

[mA･us]

① Idle 0.0011 27945 31
② Pre-processing 3.8 87 331
③ Crystal ramp-up 1.4 488 683
④ Standby 0.4 950 380
⑤ Start radio 4.1 45 185

⑦ Radio switch 2.8 152 426
⑧ Radio Tx 6.4 39 250
⑨ Post-processing 2.6 207 538

0.03  sec 3388
Total Average Current 113uA

⑥
Window widening

+ Radio Rx 6.5 87 566
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4. Current calculation tool provided by Nordic 
You can also calculate the current consumption using the "Online Power Profiler", a current calculation tool provided by 
Nordic. The Online Power Profiler is the following URL. 
https://devzone.nordicsemi.com/nordic/power/ 
 
※It does not support nRF52811 used in MK71511. 
 

 
 

Fig. 4-1 Online Power Profiler site screen 
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